Configurando Mikrotik como cliente OpenVPN

porDiego Elcain

Configurando Mikrotik como cliente OpenVPN

Vídeo aula de como conectar o um roteador mikrokit com Openvpn Server

Open VPN LOGO

 

Conectando RouterBoad Mikrotik em um Servidor OpenVPN em Linux
Mikrotik como cliente OpenVpn

Pré Requisitos
1 – Configurar o servidor para receber conexões TCP
2 – Liberar no Firewall portas TCP ao invés do padrão UDP
3 – Desativar compactação por software lzo
Passo 1
Conferir a versão das chaves. O formato PKCS #8 não é um padrão compativel com MKOS, no entanto é necessário converter as chaves para formato RSA e salvar o resultado em um arquivo qualquer, nesse caso usaremos uma extensão .rsa

openssl rsa -in ca.key -text > ca.rsa
openssl rsa -in delcain.key -text > delcain.rsa

Passo 2
Copiar e instalar os certificados para dentro da router board, usa-se a opção de arrastar e soltar.

Para importar as chaves no Sistema Operacional MKOS use os seguintes comandos.

Para Chave mestra da AC
/certificate import file-name=ca.crt
/certificate import file-name=ca.rsa

Para chave do cliente
/certificate import file-name=delcain.crt
/certificate import file-name=delcain.rsa

Renomear certificados

/certificate set name=meuCert cert1
/certificate set name=ca cert2

Passo 3
Criar internface de cliente OpenVpn
/interface ovpn-client add name=”MinhaVPN” connect-to=177.157.67.87 port=1194 mode=ip user=”delcain” password=”” profile=default certificate=delcain cipher=aes256 add-default-route=no

Passo 4
Criar rota
/ip route add dst-address=192.168.0.0/24 gateway=MinhaVPN

Passo 5
Fazer masquerade para tráfego de pacotes

/ip firewall nat add src-address=192.168.202.0/24 out-interface=MinhaVPN action=masquerade chain=srcnat

Sobre o Autor

Diego Elcain administrator